can't authenticate linux host

Dear All,

I'm trying to add new Centos Linux asset using password authentication, but i get below error

Could not discover SSH host key: Queuing task.
Starting task.
Connecting with asset centos (server ip).
Connecting to asset centos (server ip) failed with error: Connection timeout.
Failed to discover SSH host key for asset centos.
Task completed with failure. (60307)

please help

Parents
  • Hi Mahmoud,

    What version of SPP are you running?

    Are you able to connect to this host outside of Safeguard successfully?

    Please verify the Asset > Management > Network address is correct?

    Could you increase the timeout from the Asset > Connection pane > Connection Timeout > from 20 seconds to 60 for example?

    Try to test Check connection again?

    Thanks!

  • Hi Tawfiq,

    thanks for your support.

    What version of SPP are you running? 2.11.2

    Are you able to connect to this host outside of Safeguard successfully? yes

    Please verify the Asset > Management > Network address is correct? done

    Could you increase the timeout from the Asset > Connection pane > Connection Timeout > from 20 seconds to 60 for example? can't edit it

    please note that centos version is 8

  • Hi Mahmoud,

    Are you logged in to Safeguard with an admin account that has the "Asset" permission?

    - From Users > double click on the user > verify permissions enabled as this will determine if you could edit the asset or not.

    if you right click on the Asset > Select Check connection > once its finished > click on the eye icon to show the logs > click on Show more > Operations tab > this should give you more detailed log.

    Thanks!

  • thanks tawfiq.

    I have removed the asset and  added again with root account and worked fine

  • Dear Ahmed,

    same issue occurred again with Cisco switch:

    Could not discover SSH host key: Queuing task.
    Starting task.
    Connecting with asset *********).
    Connecting to asset *********failed with error: Connection refused..
    Failed to discover SSH host key for asset *******.
    Task completed with failure. (60307)

    authentication with admin (full privelleged) user

  • 1. Ensure that the password entered for admin account in Safeguard matches that of the target machines account

    2. Ensure that PermitRootLogin is set to yes in the sshd_config, also SSHD service would need to be restarted afterwards.

Reply Children