Users not automatically being added to Starling 2FA during Password Manager registration

Hello, I am working on building out our workflows for Password Manager, and in initial testing, corporate registration for use with Starling 2FA was working perfectly - a user would register through PMUser and automatically be joined to Starling 2FA with their email address and phone number. For the past two weeks, I have not been able to get users to automatically join Starling 2FA upon registration.

I have attempted this with two different instances of Password Manager - 5.8.2 and 5.9.3 - and I have also unjoined and rejoined Starling in an attempt to kick start it into working. This one holdup is preventing us from being able to finish the project and go live. I am not sure where else to troubleshoot. I appreciate any assistance. Thanks.

Parents Reply Children
  • It appears that the registration process doesn't quite do what you'd think by the name. It prepares the account in AD by making sure the mail and mobile attributes are set, but this does not register the user into Starling 2FA. The user is never populated into Starling 2FA until the first time they request a Starling 2FA token.

    This behavior is not documented anywhere, and was only discovered after some trial and error. We had even gotten on a WebEx with a support rep, and they were scratching their head as to why the user was not populated at registration, but again, as it turns out, that is not the behavior. The user is only registered into Starling 2FA upon first use.

  • I've actually been in touch with the folks that were working on that case with you. I'm going to see what we can do about getting the documentation improved to address this going forward.