issue: set-qasunixuser not updating active directory user object

I run the commands - I am not using -whatif switch.
I see the results output with all the fields filled in as expected.
I can query that user with get-qasunixuser <mydomain>\<user> and I see all the attributes I just updated. consistently. a day later - I can still see the attributes using get-qasunixuser.
BUT - 
when I look at the attributes in AD - via ARS web, console, qad powershell, or native AD powershell and expose the requisite fields, I get nothing back.

here is the command I use to set the unix attributes for the user.

$qasession = New-QASArsConnection -Domain <mydomain>

get-qaduser ds\$name |
set-qasunixuser -UserName $name `
-UidNumber $uidNext `
-PrimaryGidNumber 1000244 `
-Gecos "$gecos" `
-HomeDirectory "/export/home/$name" `
-LoginShell '/bin/ksh' `
-connection $qasession

When I later check the account using native AD commands to view those properties, using this command

get-aduser <myuser> -properties uidnumber,gidnumber,gecos,unixhomedirectory,loginshell,primarygroupid |
select uidnumber,gidnumber,gecos,unixhomedirectory,loginshell,primarygroupid

I get this

uidnumber :
gidnumber :
gecos :
unixhomedirectory :
loginshell :
primarygroupid : 

Even though - when the account is viewed using get-qasunixuser <username>, I can see the account is unix enabled

- I also ran enable-qasunixuser <username> to see if that would force <something>

nada.  Thoughts?  is there some post 'set-qasunixuser' action that I need to take ?

I have 1K users to enable this way ... and I know I could just use set-qaduser -objectattribute @{uidnumber=1234567;gidnumber=987654321} ... etc
I am more interested in using the qas toolset for this.

Parents Reply Children
No Data