SPS 6.8.1 NLA


After SPS  upgrade to 6.8.1 can not request session without enabled nla at rdp settings - policy is not valid error during the request, but if nla is enabled can get the session rdp file but during logon SPS says Authentication failed

  • Hi,

    There has been changes in the default RDP Settings starting with SPS 6.8:

    Default Network Level Authentication (NLA) settings:

    Starting from 6.8.0, the default protocol-level settings for RDP connections have changed and NLA is now enabled by default in the RDP setting policies.

    Due to this change:

    • The default RDP setting is now default_nla, where NLA is enabled.

    • RDP 4-style authentication is now cleared by default.

    To access hosts running Windows 2008 Server R2 using Network Level Authentication (NLA), select the Enable RDP4 style authentication option as well.

    Enable RDP4 style authentication: Select this option to enable RDP4 authentication within the RDP5 protocol. This might be needed for compatibility reasons with certain client applications.

    Can you try with RDP4 style authentication option to see if this is applicable in your use case?