Session resolution while using Scalus


I have an issue with Scalus tool while using 2 screens (work in extended mode).

the RDP session resolution get not compatible with screen resolution.

i tried to change rdp application from scalus management portal 

1- Windows RDP client with windows > resulted rdp session with very small resolution and can't be extended over one screen.

2- WindowsRDPdesktop or APP > resulted rdp session on half of one screen   

but when using one screen, no issue results.

thanks in advance,

  • Hi Mahmoud

    As per the admin guide for SPS:

    Using multiple monitors (Multimon) is supported. To enable Multimon, use one of the following three methods:

    • enable Display > Use all my monitors for the remote session option in the Remote Desktop Client (mstsc.exe) window of the client machine

    • use the /multimon switch on the mstsc.exe command line

    • add the use multimon:i:1 row to the RDP file

    NOTE: The Maximum display width and Maximum display height options should be high enough to cover the combined resolution of the client monitor setup. Connections that exceed these limits will automatically fail. Make sure to adjust these settings if your clients use multiple monitors. For example, if your clients use two monitors that have a resolution of 1920x1080 pixels each, set Maximum display width to 4000, and Maximum display height to 2200.

    For SCALUS, You can verify the user template file from here %AppData%\Local\SCALUS\
    - edit the rdp templates with notepad to see if use multimon switch is enabled:

    use multimon:i:1


  • Thanks Tawfiq,

    I have edited %AppData%\Local\SCALUS\ > rdp template > multimon:i: to 0

    and selected (WindowsRDPdesktop or APP) from scalus management portal.

    then get it working well.