How to configure IIS to respond with a FQDN in the header

I would normally research this for myself, but am short of time and asking is quicker

I have my IT shop deployed onto IIS 7 in customer's DEV domain.   They would like people to be able to access it from their desktops in their production domain (purely for demo purposes)

If we put the FQDN into the URL, the address is resolvable and the initial connection to the IT Shop is made, but the browser then gets redirected to the "hostname" of the DEV server and the we get a "server not found" message.

I'm not an IIS expert, so if someone could just tell me how to get IIS to respond with its Full Qualified Name in the header then the browsers in the other domain(s) will work.

From memory, is it something like setting an Alternate Hostname ??

Thanks

Jon.

  • Thanks.....but.....that's not going to make any difference is it ?  

    I can connect to

    http://hostname.fqdn/idm

    but then I get a redirection to a page

    http://hostname/idm/page.axd......blah

    so the customer's DNS will resolve hostname.fqdn  but not hostname.  So I need the redirection page to be fully qualified.

    The same thing happens if I construct the initial URL with an ip addr.

    J.

  • Hi Jonathan!

    I think the easiest way is to change the binding-parameter. I hate the creepy IIS-GUI, so here my solution:

    Open the applicationHost.config normally in C:\Windows\System32\inetsrv\config. Look for the <sites> tag and the child node <bindings>, then edit the node <binding>

    for example

    <binding protocol="http" bindingInformation="*:80:hostname.fqdn" />

    This should solve your problem.

    If not (or if you have the httpredirect-module installed) then look in the same file for the <location> nodes and change the hostnames to FQDN too.

    Hope that helps,

    N.

  • Sorry.  Didn't work. 

    I did a seach for all instances of the hostname in the file.  It only appeared in the bindings section, where I changed it as suggested.

    I think I am going to have to have to see if the customer can add the domain to their DNS domainpaths on the windows clients, but this is a fudge rather than a fix.

    There must be a way of doing this.   Do I need the redirect module ?

    J.

  • Look for the http://hostname/idm/ URL in the application's web.config. Sounds like you may need to insert the FQDN into the URLs in the <applicationpool> section.