This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

UNSAccountB process is not firing for INSERT events for Provisioning using Powershell Connector


I want to Create Active Directory Accounts using the Powershell Connector with the OOB AD Sample.xml definition file in my Sync Editor Project.

Right now I'm able to execute the Full Sync, so the AD Accounts are under UNSAccountB but I can't Provisioning new acccounts to the Target System.

I've created a new custom UNSAccountB process for INSERT events and it's not being fired. When I run the Simulation in Designer the Process Step says "Not Generated".

Here's the Pre-Script for Generating and Generating Conditions:

The process step is a process task Projector Component - AdHocProjection with the Following Properties:

Also I've setup the provisioning process operation in order to execute the Sync Workflow for Provisioning:


I appreciate any help!


  • What I would do is: 1. Validate all values in your pre-script for your test sample against feasibility. Especially the Connection.GetSingleProperty call. 2. Debug the script call of DPR_GetAdHocData in your pre-script in the System Library using your sample values. You will find the exact place where the exception occurs.
  • I just switched the GetSingleProperty columns from the query and worked. The issue was in the pre-script all the time. Thanks for all your help Markus!