Object <User1,User1> cannot be deleted while objects of type <Request procedures> are still assigned. ??

Where can I delete request procedures that are still assigned to this user. I wanted to delete it and got this error:

Object <User1,User1> cannot be deleted while objects of type <Request procedures> are still assigned.


  • Hi Denis,

    try to use the ObjectBrowser, load the User1 person object and execute the method "Delete (including dependent objects(" from the Object menu.

    Please be aware that this will also delete all the assigned request procedure or accounts for this person object.


  • Hi Denis,

    if you cleanup dependencies first, you can do this via script too. You'll be able to delete the object, but this is a very dangerous way: it can bring you a lot of loose entries in different tables. The way Markus described is the better way but with the disadvantage he mentioned (all dependencies of your object will be deleted). I just want to give you a hint to keep it back in mind:

    Technically you can not delete the object, because the standard order fills the column UID_PWOORIGIN in PersonInBaseTree. If you clear it (and afterwards the entry in PersonWantsOrg), you'll be able to delete the object. Please be aware that further dependencies can exist (like UID_SHOPPINGCARTORDER aso.)

    Best regards,


  • This is a bit of a nuisance really. A user is assigned a new manager say using the OOB new manager request and then they cannot be simply deleted.

    How can the request procedure be removed without using the Delete and remove all dependant objects? I have scheduled process that looks for disabled expired accounts of a certain type and deletes them. This gets stuck because of this problem. Is there a neater solution?

  • Sorry to reopen this thread, but I'm facing this very same problem with IdentityManager v7.0.1 and I dont seem to be able to fix it at all:

    * If I try to delete the user from Manager, I get this same error: Request procedures are still assigned.

    * If I try to delete it with the ObjectBrowser , same error appears.

    * Using "Delete with dependencies" pops up a number of objects but the error "You do not have delete permissions for this object (QER-32569d349511445a87bddce122e73e9b - f734c898-2863-42cc-80e2-dae2bed0d510) appears after clicking Yes.

    * In PersonWantsOrg->Request Procedures, the OrderState shows up as "Pending" and it is locked.

    Do you have any suggestions?
  • Hi Geraldine,

    Thanks for answering.

    Somehow I've been able to cancel the request by removing the user from the shops. Now the request appears as "cancellled" , reason " The product is no longer available". That seems right. But still I cannot delete the user, same message: Request procedures still assigned.

    I've readded the user to the shops, assigned the product and removed it perfectly. Then again, I'm still unable to delete the person.
  • You are saying that you are still unable to delete the person.

    - Did you check that all request are in a final state?
    - What error are you getting in detail?
  • Hi Markus,

    - The user has no pending requests now. Or at least none that I can see (maybe I dont have the skill to look deeper). In PersonWantsOrg, the request that was pending now shows up as Aborted (OrderState). So I guess all requests are in final state.

    - The error was "Object <xxx (yyyy)> cannot be deleted while objects of type <Request procedures> are still assigned." . I've retried deleting the user before sending this post and I get a newer error message:
    "Error during execution of 'OnSaving' in logic module VI.DB.Entities.ReferentialIntegrityLogic'.
  • Do you have a customized OnSavingScript at the person table?